Our vendor has tested and deployed their fix to production. The Digital Onboarding Engineering team is making a few final changes on our side to support this fix. Our engineering team is still determining the exact turnaround time.
Posted Dec 04, 2025 - 14:37 EST
Update
Our partner continues to actively investigate the issue with Xfinity and Spectrum users being unable to view the Card on File widget. They have identified a potential solution and will need next week to continue testing to ensure it resolves the problem fully.
Posted Nov 21, 2025 - 16:34 EST
Update
Our partners are continuing to work around the clock to resolve this issue. At the moment, the impact appears to be limited to random users on Xfinity and Spectrum.
Posted Nov 19, 2025 - 18:07 EST
Update
Our partners are continuing to work around the clock to resolve this issue. At the moment, the impact appears to be limited to random users on Xfinity and Spectrum, rather than all users on those networks.
Posted Nov 18, 2025 - 13:15 EST
Identified
Users with Xfinity or Spectrum are currently unable to view the Card on File widget. All other Internet service providers display the widget as expected.
We are in communication with our partner, and they have confirmed that they are taking this issue very seriously. They are actively working with Xfinity and Spectrum to resolve the problem.